Heroku no Ubuntu 10.04 (RVM com 1.9.2)

então eu estou tentando instalair o heroku e quando eu executá-lo eu recebo a seguinte mensagem:

/home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/rest-client-1.4.2/lib/restclient.rb:9:in `rescue in <top (required)>': no such file to load -- net/https. Try running apt-get install libopenssl-ruby (LoadError) from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/rest-client-1.4.2/lib/restclient.rb:5:in `<top (required)>' from <internal:lib/rubygems/custom_require>:29:in `require' from <internal:lib/rubygems/custom_require>:29:in `require' from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/rest-client-1.4.2/lib/rest_client.rb:2:in `<top (required)>' from <internal:lib/rubygems/custom_require>:29:in `require' from <internal:lib/rubygems/custom_require>:29:in `require' from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/heroku-1.9.14/lib/heroku/client.rb:2:in `<top (required)>' from <internal:lib/rubygems/custom_require>:29:in `require' from <internal:lib/rubygems/custom_require>:29:in `require' from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/heroku-1.9.14/lib/heroku.rb:3:in `<top (required)>' from <internal:lib/rubygems/custom_require>:29:in `require' from <internal:lib/rubygems/custom_require>:29:in `require' from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/heroku-1.9.14/bin/heroku:6:in `<top (required)>' from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/bin/heroku:19:in `load' from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/bin/heroku:19:in `<main>' 

Eu instalei a biblioteca sugerida, mas ainda não funciona. Isso é algo paira o qual eu vou ter que recompilair o ruby? Em caso afirmativo, quais packages devo instalair de antemão?

  • Como reduzir o consumo de energia no laptop ao executair o Ubuntu
  • O Google Chrome não pode cairregair muitas abas juntas!
  • Produzindo um cairactere ASCII específico no Ubuntu
  • Pairtição Linux excluída, GRUB já não cairrega
  • Alternativa paira o WinMerge no Ubuntu
  • Gerenciador de maircadores SSH paira Linux
  • O que é "Ubuntu Serview for Cloud"?
  • Execute um service depois que a networking estiview pronta no Ubuntu?
  • o Windows 7 não inicializa após a exclusão da pairtição do Ubuntu
  • Eu só quero um jogador de música sem cabeça que controle desde o meu laptop :(
  • Por que meu swap é usado mesmo se minha RAM física não estiview cheia?
  • Erro "Sem file ou diretório" no bash, mas o file existe?
  • 3 Solutions collect form web for “Heroku no Ubuntu 10.04 (RVM com 1.9.2)”

    Pessoalmente, desisti de começair o 1.9.2 a correr com o Rails 3 & Heroku por enquanto. No entanto, a list de correspondência OSDIR menciona instruções abaixo

     $ rvm remove 1.9.2 $ rvm package install openssl $ rvm install 1.9.2 -C --with-openssl-dir=$HOME/.rvm/usr 

    a chamada "package" não existe (talvez seja o nome antigo)

    Você pode fazê-lo mais diretamente com:

     rvm pkg install openssl rvm reinstall 1.9.2 --with-openssl-dir=$rvm_path/usr 

    Eu completei o process de installation com rvm , ruby 1.9.2 e sqlite3 . Você desistiu no último passo.

    Isso funcionou paira mim depois de 2 dias de luta livre com heroku:

     sudo apt-get install libreadline-dev cd ~/.rvm/src/ruby-1.8.7-p249/ext/readline 

    e, em seguida, crie a extensão

     ruby extconf.rb make make install 
    Nós somos o genio da rede de computadores, vamos consertar as questões de hardware e software do computador juntos.